# YAML Test Matrix

--- &test-27NA
  Title: Spec Example 5.9. Directive Indicator
  Tags: [ 1.3-err, directive, spec ]

YAML

%YAML 1.2
--- text

Expected Events

+STR
+DOC ---
=VAL :text
-DOC
-STR

Expected JSON

"text"

cpp-event

 ok

hs-yaml-event

 ok

java-event

 ok

nimyaml-event

 ok

perl5-pegex-event

 ok

perl5-pp-event

 ok

pyyaml-event

 ok

ruamel-event

 ok

hs-yaml-json

 json_ok

java-json

 json_ok

js-yaml-json

 json_ok

perl5-pp-json

 json_ok

perl5-tiny-json

 json_ok

pyyaml-json

 json_ok

ruamel-json

 json_ok

perl5-syck-json

 json_diff
"%YAML 1.2 --- text"

libyaml-event

 error
+STR
Parse error: found incompatible YAML document

luajit-json

 error
luajit: found incompatible YAML document at document: 0

stack traceback:
	[C]: in function 'load'
	/bin/luajit-json:6: in main chunk
	[C]: at 0x004044a0

perl5-pm-json

 error
YAML Error: Expected separator '---'
   Code: YAML_PARSE_ERR_NO_SEPARATOR
   Line: 1
   Document: 2
 at /lib/perl5/YAML/Loader.pm line 88.

perl5-pm-pl

 error
YAML Error: Expected separator '---'
   Code: YAML_PARSE_ERR_NO_SEPARATOR
   Line: 1
   Document: 2
 at /lib/perl5/YAML/Loader.pm line 88.

perl5-xs-json

 error
YAML::XS::Load Error: The problem:

    found incompatible YAML document

was found at document: 1

perl5-xs-pl

 error
YAML::XS::Load Error: The problem:

    found incompatible YAML document

was found at document: 1

ruby-json

 error
/usr/lib/ruby/2.3.0/psych.rb:380:in `parse': (<unknown>): found incompatible YAML document at line 1 column 1 (Psych::SyntaxError)
	from /usr/lib/ruby/2.3.0/psych.rb:380:in `parse_stream'
	from /usr/lib/ruby/2.3.0/psych.rb:463:in `load_stream'
	from /bin/ruby-json:6:in `<main>'

perl5-pp-pl

 na
'text'

perl5-syck-pl

 na
'%YAML 1.2 --- text'

perl5-tiny-pl

 na
'text'

pyyaml-py

 na
'text'

ruamel-py

 na
'text'